System Requirements

Supported Platforms

Mobile

Requirements

  • Any platform: OpenGL ES3.0 and higher
  • Android: supported from Android 6.0. API level 23
  • iOS: supported from iOS 10.0. Minimal supported device โ€” iPhone 5s

Desktop

Requirements PC

  • Support OpenGL 4.3 and up (4.1 for MacOS)
  • Windows 8.1 and up
  • MacOS 10.13 and up
  • VC++ 15 and up runtime available

Supported Browsers

Mobile*

Desktop

* Banuba Web SDK supports any browser with WebGL 2.0 and higher. Since iOS currently doesn't support WebGL 2.0, Banuba SDK for Web cannot be supported on iOS devices. All supported browsers are listed here.

Requirements

  • WebGL 2.0 and higher.

Supported languages

LanguagesPlatforms
Objective-C
Swift 5
MacOS
Kotlin
Java 7
Android
C++ 17All
C#Unity
JavaScriptWeb
Python3MacOS, Windows, Ubuntu
Last updated on